T1: Introduction to the MatCalc graphical user interface (GUI)

This tutorial was tested on
MatCalc version 6.00 rel 1.000
license: free
database: none

This first tutorial provides a brief tour of MatCalc's user interface and explains how to perform basic file operations.

Contents

  • Appearance of the graphical user interface
  • Menus and toolbar
  • Console window
  • Command history
  • Configuring the layout of the GUI
  • The 'File' menu
  • Creating a new workspace file
  • Modifying the working directory
  • Adding workspace information
  • Saving and closing files
  • Getting help

The graphical user interface

Screen layout

When MatCalc is first opened, the screen appears as shown below (Windows version).

 MatCalc screenshot

The table below gives brief descriptions of the different areas of the screen.

Menu bar The main menu (see below and the relevant section in the Reference book).
Toolbar Icons giving quick access to frequently used functions (see below)
Quick access bar Icons giving quick access to window management options (see below).
Console This window has an area for entering command-lines and an area that shows output from calculations and other operations; more information is given below and in Tutorial 12.
Options window Context-sensitive options to change the way information is displayed. Tutorial 2, Tutorial 4 and Tutorial 5 give more information about the Options window.
Variables window A list of MatCalc's built-in variables with their current values. See Tutorial 4 and Tutorial 5 for more about variables.
Information on variables Notes on the currently highlighted entry in the variables window (meaning of variable, units, etc.).
Nodes window List of nodes used in simulation. Multiple nodes are used in advanced calculations.
Status bar Gives information on the current state of the system (temperature, time, etc.) and on the contents of graphical windows (see Tutorial 4).

As with any typical GUI application, this gives access to a number of sub-menus. The File and Help menus are documented in this tutorial, and the contents of the other menus will be described in more detail in subsequent tutorials.

File opening, saving and closing files (see 'File operations' below)
Edit text-editing commands such as undo, redo, cut, copy, paste
Global commands for setting up the system (see Tutorial 2 and subsequent tutorials)
Calc commands for the most frequent types of calculation (see Tutorial 2 and subsequent tutorials)
Simulation, Monte Carlo, Regions commands for starting various types of calculation
Script to run scripts (more on this in Tutorial 13)
View to configure the GUI and create new windows for the display of results (see Tutorial 4 and Tutorial 5)
Help see Getting help below

Comprehensive information about the menu items can be found in the reference book.

Toolbars

The toolbar area contains a number of icon groups:

File etc

 MatCalc Toolbar File
L-R : New, open, save, close workspace, print, contents

Working directory and script

 MatCalc Toolbar Toolbar
L-R: browse working directory, run script

Edit

 MatCalc Toolbar Edit
L-R: Undo, redo, cut, copy, paste, find

Calculation

 MatCalc Toolbar Calculation
L-R: Stop current action, single equilibrium, stepped equilibrium, search phase boundary, precipitate kinetics calculation, select calculation state, save into current calculation state, load from current calculation state, select calculation buffer.

Manage windows

 MatCalc Toolbar Manage Windows
L-R: Show/hide console, create new output window

Right-clicking on the toolbar area gives a menu allowing the user to control which windows and which icon groups are to be displayed on the screen:

 MatCalc Toolbarmenu

Quick access bar

The quick access bar enables you to customise the appearance of your MatCalc session by displaying, hiding and rearranging the windows.

The table below gives brief descriptions of the different areas of the screen.

Wizard Wizard
Hide all Hide options, variables, consoles and nodes. Workspace output windows remain visible.
Console Show/maximise/hide the console window (three-way toggle).
Options Show/hide the options window.
Variables Show/hide the variables window.
Nodes Show/hide the nodes window.
Start Start calculation (green arrow), stop calculation (red 'x' shown while calculation is running). Green tick-mark indicates successfully executed calculation.
Freeze Freeze window updates during calculation.
Fit to viewport Fit windows into viewport (visible area on screen).
Zoom in Zoom in.
Zoom out Zoom out.
Open navigator Display an overview all open windows, enabling you to find the windows and regions of interest.
Display mode Clicking the down-arrow to the right of this icon reveals three options: windowed - output is in moveable windows on the screen, tabbed - output is accessible via browser-style tabs at the top of the viewport, expose - automatic organisation of output, with minimisation of system windows such as options, console, etc. Clicking on the background of the viewport area brings back the previous display mode (windowed/tabbed).

Console

This window allows command-line input, as an alternative to using the graphical controls. Commands can also be grouped into script files, for easier and more rapid execution of repetitive or complex tasks. More on the console, command-line syntax and scripts will be found in Tutorial 12: Using the MatCalc console and Tutorial 13: Introduction to scripting. The console can be shown or hidden using View > Show > Show console, pressing the F4 key or clicking on the  MatCalc Icon show console icon.

MatCalc 6 uses a new formalism for the command-line input. While the scripts and commands used in the older versions are recognized by the current version, the old command formalism is to be typed in 'MatCalc 5 console' window.

Command history

The command history window can be made to appear by selecting the console window and either clicking on the up-arrow icon or pressing Ctrl + up-arrow. This window gives a chronological list of all the commands entered in the Console.

 MatCalc command history window

A command can be selected using the mouse pointer or arrow keys. Right-clicking on the command displays the following menu. On the right-hand side of the menus in MatCalc are keyboard shortcuts for the more commonly used commands. It can be seen from the image below that it is sufficient to press the Enter key to execute the selected command.

 MatCalc command history menu

Previously used commands can also be accessed in the Console window itself; pressing the up-arrow key displays the most recently entered command, and pressing it repeatedly scrolls through recent commands in reverse chronological order. The command displayed can be edited then executed by pressing the Enter key.

Configuring the layout

In addition to the display options described above, icon groups and the Options, Variables, Nodes and Console windows can be detached from their locations and rearranged as desired by dragging and dropping. In this case, they are given title bars similar to that of the MatCalc console. The Console, Options, Variables and Command History windows can also be attached to or detached from the left-hand column area as required.

Right-clicking on the menu bar brings up a menu allowing the user to show or hide menu icon groups and windows as described above.

View > Show

Enables the following windows to be displayed or hidden: console (F4), options (F3), variables (F2), node manager (Shift + F5)

View > Select window font

Here the user can select an alternative font/font size for the display of numerical output. This does not affect the appearance of the console, nodes, options and variables windows.

View > Select application style

The overall appearance of MatCalc can be modified here. The different options offer a greater or lesser degree of free space around text items, stronger or more subtle contrast etc. - experiment until you find an option that suits you.

View > Display window IDs

This switches the numbers /0/, /1/, /2/, etc. in the top left-hand corner of the output windows.

View > Restore window positions (Alt + Shift + R)

Restores all windows to their default positions.

View > Windows

Using this menu, the output windows can be brought to the front (if hidden behind others) or restored to their original size (if minimised).

File operations

The 'File' menu

Clicking on File in the menu bar opens the following menu:

 MatCalc file menu

Creating a new workspace file

The workspace is the basic file type in MatCalc. It contains all the necessary information on the calculation or series of calculations under consideration, comprising inputs (elements, phases, compositions, thermodynamic and mobility data) and outputs (results of calculations, graphs, etc.). Saving the workspace preserves all this information for future use.

Click on the  MatCalc icon new icon, open New from the File menu or click Ctrl + N. The following dialogue box will appear:

 MatCalc new file

Select MatCalc workspace from the drop-box. This runs a script file called autonew.mcs, which makes two additional windows appear: Phase details and Phase summary. When the new workspace is first created, the Phase summary and Phase details windows show messages indicating that no phases have yet been selected. The workspace is now ready for thermodynamic or precipitation calculations to be set up and performed.

 MatCalc Screenshot

Working directory

The working directory is the directory opened by default when saving new files or opening existing ones. Clicking on Working directory… in the File menu allows the user to designate an existing directory as the working directory or to create a new directory for this purpose. MatCalc remembers your chosen working directory for next time.

 MatCalc working directory

The paths of the current working directory and of recently used working directories are listed to the right of Recent working dirs…, allowing any of these directories to be selected easily.

 MatCalc working directory menu

The same information is also available in a drop-box in the toolbar area:

 MatCalc working directory dropbox

Adding workspace information

Clicking on Workspace info… opens a box in which information about the current workspace can be entered. This is useful for details of the assumptions used in the calculation, the sources of experimental data, etc.

 MatCalc workspace info

Save, Save as, close

Workspaces can be saved using Save… from the file menu, the keyboard shortcut Ctrl + S or the  MatCalc icon save icon on the toolbar. To save an existing workspace under a different name, select Save As… from the file menu.

To close a file, choose Close Workspace from the file menu, press Ctrl + Shift + W or click on  MatCalc icon close.

WARNING

Do not close the individual windows on the screen before saving, or their contents will not be saved!

Getting help

The MatCalc help files are accessible on this website. At present, no local installation is provided.

In the Console, typing a question-mark will display a list of available commands. These will be discussed in more detail in Tutorial 12.

Subsequent articles

tutorials/t1.txt · Last modified: 2017/10/23 16:41 by pwarczok